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Introduction to Datawatch
License Server

Datawatch License Server v15.0 is a licensing management application for Monarch.
Licenses for users are managed through instances. An instance defines the product and the
license to which a user is entitled access. When a user attempts to log into Monarch, the
application calls Datawatch License Server by instance name and checks whether or not this
user exists within this instance. If the user does exist, he or she is authorized to log in and the
license that this user is entitled to is automatically applied.
The Datawatch License Server v15.0 application consists of two components:


License Service – The service that handles all interactions between Monarch and the
application database that stores data about the instances, licenses, and users.



Configuration Utility – The desktop application that allows managing instances, licenses,
and users.

The following topics describe how to start Datawatch License Server and how to use Server
Explorer. This guide also provides information about Datawatch License Server settings and
troubleshooting.
Datawatch License Server is a distributable application, which means that you can install both
components onto one machine or you can install them separately onto different machines
within a network. For information about installation of the application, refer to Datawatch
License Server v15.0 Installation Guide.
Note that this version of License Server supports Monarch versions 14.1 and later, including
Monarch versions 15+.

New Features in this Version


Implementation of administrative policy settings



Cross-instance administration (for user/session management and reporting)



Automatic license check-out



Generation of checked-out users reports



“Pure” instance administrators no longer consume a license



Implementation of a “Require AD Authentication" option



Wildcard support for ConfigMachineNames in the license file
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Check Machine Name functionality for license creation



Various bug fixes and customer requests

Starting and Connecting to Datawatch
License Server

To begin working with Datawatch License Server, you first launch the Datawatch License
Server Configuration Utility and then connect it to a license server, i.e., a computer with the
License Service component installed in it. The license server may be either the local machine
or a machine in your network.

Steps:
1. From the Windows Start menu, run License Server Configuration Utility. The
Connect to Server dialog box appears.
2. In the Server Name drop-down list, select Browse for all to find the name of the server
on which the Datawatch License Server component had been installed that you want to
connect to.

3. Select the required server name from the window that appears and click OK.
4. In the Instance Name field, do either of the following:
•

If you are connecting as the system admin user, leave the field empty. The system
admin user account is not attached to any instance.

•

If you are connecting as a license instance administrator user, enter the name of the
required instance.
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5. In the Authentication Type field, select either of the following:
•

Server – Select to specify the user credentials that will be stored in the License Server
database.

•

Active Directory – Select to specify the user credentials from Windows Active
Directory.

NOTE
If you are the system administrator user, you can only connect
with the Server authentication type.

6. In the User Name field, enter your user name or leave the domain user name autopopulated from Active Directory.
7. In the Password field, enter your password.
If you are connecting to a license server as the system admin user for the first time, you
must use the default user name “admin” and password “password,” which were created
during installation of the application. For details about default system admin credentials,
refer to Datawatch License Server v15.0 Installation Guide. You can change credentials for
the system administrator after you have connected to the license server.

NOTE
If the system administrator username or password are changed,
please make sure that you record the details securely, as they
cannot be recovered if they are forgotten.

8. If you are using the Active Directory authentication type, enter your domain name.
9. Click Connect.
When the connection has been successfully established, the server information will be
displayed in Server Explorer.
To disconnect from the Datawatch License Server, simply launch the Datawatch License Server
Configuration Utility and then click File > Disconnect.
After you disconnect from the license server, you can connect back at any time by selecting
File > Connect to server. If you are currently connected to any license server, you can
initiate a connection by clicking Connect to server in Server Explorer.
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About Datawatch Licenses
The license specifies information that Monarch uses for granting access and features to users.
There are two types of licenses used in Datawatch License Server:


Global license – The Datawatch global license used with the Datawatch License Server
installation. This license is used as the default license for servers and instances until you
load a custom license for them.



Custom license – A different license that you load for specific servers or instances. If you
load a custom license to a license server, this license is used as the global license for each
new instance created on this server.

Let’s assume that you have been provided a global license that allows 3 instances and
Monarch Classic. When a new instance is added, the application will automatically configure
the instance to be licensed for Monarch Classic with all other attributes of that global license.
If new users who use Monarch Complete need to be added, then an additional (custom)
license file must be provided, and this license can be used to create a new instance, separate
from the other instances.
License information is displayed in the content pane when you select a server or an instance in
Server Explorer. All license fields are based on the specific Datawatch product for which the
license is intended.
To help ensure that licenses do not expire inadvertently, a warning level color indicator and
tooltip is configured for each instance to show the number of days remaining until a license
expires. If you disable the license expiry messages for clients, ensure you log in to License
Server regularly to see these indicators.

Whereas previous versions of the application required fully defined ConfigNames and
MachineNames, License Server v15.0 now accepts licenses with wildcards in these license
options.
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Supported wildcards:


Asterisk ( * )
The asterisk in a wildcard matches any character zero or more times. For example,
"comp*" matches anything beginning with "comp" which means "comp," "complete," and
"computer" are all matched.



Question mark ( ? )
A question mark matches a single character once. For example, "c?mp" matches "camp"
and "comp." The question mark can also be used more than once. For example, "c??p"
would match both of the above examples, as well as "coop."

Common cases for wildcards for 'MachineNames' license options:


*.domain.com - License could be used on any machine that belongs to 'domain.com';



machineName??.domain.com - License could be used on machines that belong to
'domain.com' with names starting with "machineName" + any 2 symbols.

Using Server Explorer
When you are connected to License Server, the Server Explorer pane on the left displays the
following information as shown in the figure below:


Server name



Instance name – For a licensed-instance administrator user
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To expand an item in Server Explorer, click the arrow icon next to the item.

In the Search field located at the top of the left-hand pane of the Server Explorer, you can
search for the following items on currently connected license servers:


Users – You can run a search for existing users by user name



Sessions – You can run a search for active sessions by user name



Features – You can run a search for existing features by feature name

The content pane on the right-hand side of the Explorer displays the contents of the item
selected in the left-hand side. If it displays a table, for example, a user table, you can sort the
table content by clicking the column names. If your table has several pages, you can use the
page navigation options found below the table.

Cross-Instance Administration
License Server v15.0 provides an “all instances” view of the application. This view provides
administrators with the ability to manage users and sessions on a global scale, as well as
generate reports for a single or all server instances. This view is accessed by clicking All
Instances on the left-hand pane of the explorer.
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Server information, including whether the server is running, the number of valid and invalid
instances, total number of enabled users, total number of instance administrators, and the
like, is displayed in the right-hand pane of the explorer.

Clicking on the Users List link under All Instances displays all active users in all server
instances.
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Likewise, clicking on the Session List link under All Instances displays all active sessions in
all server instances.

In the All Instances view, administrators may generate reports for a single or n number of
server instances. This selection is made by clicking the Instance selector drop-down, as
shown in the figure below, and then ticking the boxes of instances from which you wish to
generate a report. The selector below the instance selector allows you to choose what type of
report to generate.
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The example below shows a session list report for all server instances available.

System administrators may also easily check the name of a server for license creation. To do
so, right-click on the server name and, from the options that display, select Check Machine
Name.

The machine and/or domain machine names display in a dialog. Clicking on the Copy to
Clipboard
icon located to the right of the Machine name or Domain machine name
fields copies the name to the clipboard for easy pasting during license generation.
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Managing Instances
An instance determines which users can use Monarch. Each instance contains a license
specifying product features that are granted to users upon log in to the application.
In Server Explorer, the following elements may be viewed for each instance:


Users List



Session List



Features



Reporting

You can add new instances, as well as edit and delete existing ones. What you can do with
instances also depends on your user type.

NOTE
Datawatch License Server supports simultaneous work of users
in an instance. To update the status of instance elements, rightclick the required instance element or the instance item itself in
Server Explorer and then click Refresh.
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Adding an Instance
When you add an instance, it is created with a default name on the currently selected license
server. The new instances are numbered incrementally as you add them, for example,
DefaultInstance0, DefaultInstance1, and so on. You can rename the created instance later.
The default Datawatch global license that you used with the Datawatch License Server
installation is automatically applied to each newly created instance. You can load a new license
for a specific instance. This license will be applied to this instance only. You can also export
the license from an instance to your computer.

Steps:
1. In Server Explorer, click the license server on which you want to add a new instance.
2. Do either of the following:
•

Right-click the server name and then select Add Instance.

•

On the File menu, select Add > Add Instance.

The new instance item appears in Server Explorer; by default, this new instance is named
DefaultInstance0. The instance license information appears in the content pane on the
right.

3. In the Instance Name field, enter a new meaningful name for the instance. If you want to
clear the entered name, click Reset and provide another name.
4. Click Save.
5. If you want to load a different license for this instance, click Load License.

License Server 15.0 User Guide

11

6. In the Open dialog box that appears, select the required license file in the .lic format and
then click Open. The updated instance license information is displayed in the content
pane. The loaded license applies to this instance only.

NOTE
You can create instances and load licenses only if you are the
system admin user.

Editing an Instance
Steps:
1. In Server Explorer, select the instance that you want to edit. The instance details are
displayed in the content pane on the right.
2. If so desired, modify the instance name and then click Save.
3. If necessary, click Load License and load a new license for the current instance.

NOTE
Always refresh the modified instance in the Server Explorer
after you make changes to it. To do so, right-click on the
modified instance and then select Refresh.

Deleting an Instance
Steps:
1. In Server Explorer, select the instance that you want to delete.
2. Right-click the instance and select Delete Instance.
3. Click OK to confirm the deletion. The instance is deleted from the Datawatch License
Server database together with all users and other instance elements.
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Managing User Sessions
The session list displays the active sessions of users who are currently logged in to Monarch. It
also shows the license instance of admin users who are currently logged in to Datawatch
License Server.
To view the session list for a specific instance, navigate to the required session list in Server
Explorer and click the arrow next to this session list to expand it. Users currently logged in are
displayed under Session List in Server Explorer and in the Sessions table in the content pane.

You can run a search in the session list by user name. Information on the total number of
active sessions is displayed at the bottom of the Session list.
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Steps:
1. Click the user name in the Sessions table. The session details are displayed in the content
pane.

2. You can end the current session for users in any of the following ways:
•

Individually for specific users – Click End Session either in the session details or
in the Sessions table.

•

For all logged in users at once – Click Logout All below the Sessions table in the
content pane.

Steps:
1. Click Refresh below the Sessions table.
2. Right-click Session List in Server Explorer and select Refresh.
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Managing Features
The features available to users depend on the Datawatch product defined in the license file for
a specific instance.
To view a list of features available in the license for a specific instance, navigate to the
Features element of the required instance in Server Explorer. Click the arrow next to
Features to expand the list. The list of all features available in the license file is displayed in
Server Explorer.

You can run a search in the feature list by feature name.
To enable features, select the check-box by the feature name.

NOTE
By default, all features are disabled for all users.
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Reporting
You can generate three types of reports in Datawatch License Server: a session list report,
which includes information on all users using a specific instance over a specific period of time;
a user history report, which lists all users who have logged into Monarch, as well as their first
and last login times; or a checked-out user report, which includes a list of all users who have
checked out their license to work offline.

These reports are displayed under Reporting in Server Explorer until you disconnect from the
license server. You can go back to a report at any time and regenerate or refresh it. Using the
toolbar above the report, you can:


Refresh the report



Browse report pages



Display the report in print preview mode



Print the report



Export the report to a number of formats



Change the page setup for the report

You can also adjust the report display by using the zoom tools at the bottom of the window.
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Steps:
1. In Server Explorer, navigate to the instance for which you want to run a session list
report.
2. Click Reporting.
3. In the Report Type drop-down, ensure that Session List Report is selected.
4. In the content pane, specify the required date and time in the From and To fields.
5. Click Generate Report.
The generated report is displayed in the content pane.

6. To clear the session list report and begin generating a new report, click Clear Session
History.

NOTE
If you do not specify a time span for the session list report, then all
the entire session history will be extracted for the report. This may
take a long time.
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Steps:
1. In Server Explorer, navigate to the instance for which you want to run a user history
report.
2. Click Reporting.
3. In the Report Type drop-down, ensure that User History is selected.
4. Click Generate Report.
The generated report is displayed in the content pane.

Steps:
1. In Server Explorer, navigate to the instance for which you want to run a checked-out users
report.
2. Click Reporting.
3. In the Report Type drop-down, ensure that Checked-Out Users is selected.
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4. Click Generate Report.
The generated report is displayed in the content pane.

Once a user checks his/her license back in, the user’s name is removed from this list.
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Managing Users
To access all users available within an instance, click the server name in Server Explorer, click
the instance name, and then click Users List as shown in the image below.

You can sort the Users table in the content pane by clicking on a column name. If you click on
the Email column, for example, users will be sorted in ascending or descending order
according to their email addresses. You can also run a search among the existing users by
typing a user name in the Search in list field.
You can add a new user, as well as view, edit, and delete an existing user. You can also import
users in a number of ways.
Information on the total number of and enabled users in the License Server database is
displayed at the bottom of the Users list.
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About User Types
There are three types of users in Datawatch License Server:


System admin user – This user is created during the installation of Datawatch License
Server. Only one system admin user can exist in the application. For more information
about the creation of the system admin user, refer to Datawatch License Server v15.0
Installation Guide.



Licensed-instance admin users – These users are created by the system admin user. A
licensed-instance admin user can create and manage end users in the instance to which he
belongs.



End users – These are the end users of Monarch. They cannot log in to Datawatch
License Server. End users are created by the system and licensed-instance admin users.
The system and licensed-instance admins manage product licenses for end users through
instances.

The table below shows the differences in permissions that are granted to system admin and
licensed-instance admin users.
USER TYPE

CAN CREATE
INSTANCES?

CAN LOAD
LICENSES?

CAN CREATE
SYSTEM ADMIN
USERS?

CAN CREATE
END USERS?

System admin

Yes

Yes

Yes

Yes

Licensed-instance
admin

No

No

No

Yes

End user

No

No

No

No

Before end users can log in to Monarch, the system admin or a licensed-instance admin must
add them to the list of users in the corresponding instance in Datawatch License Server. The
system admin must also add licensed-instance admin users to ensure they are able to log in to
Datawatch License Server and to Monarch.
The user type also defines which applications are affected when enabling or disabling access
for a specific user. For end users, this affects access to Monarch. For licensed-instance admin
users, this affects access to Monarch and, additionally, to Datawatch License Server itself.

Adding a New User
You can create users of different types based on your user type permissions in the License
Server Configuration Utility:


If you are a system admin user, you can create licensed-instance admin users and end
users in any instance that you created.



If you are a licensed-instance admin user, you can create only end users in the instance to
which you belong.
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Steps:
1. Navigate to the users list in Server Explorer.
2. Do either of the following:
•

Right-click Users List and click Add New.

•

Click Add New under the Users table in the content pane.

An empty user addition form appears.

3. Enter the user’s name.
4. If you want to enable the Server authentication type for the user at server connection,
enter the user’s password.
5. Re-enter the user’s password in the Confirm Password field.
6. Enter the user’s full name.
7. Enter the user’s email.
8. Select the Enabled checkbox to activate the user’s account.
9. If you want to enable the Active Directory authentication type for the user, stick the AD
Login Enabled check box.
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10. If you enabled Active Directory login, provide the domain name and user name from
Active Directory in the AD Login Info field that appears. To do so, carry out the following
steps:
•

Click the Look up button.

•

In the Import from Active Directory dialog that appears, specify the name of the
domain in which to search for the user.

•

To filter the list of users returned, tick the box for LDAP query and then enter a
search string into the field provided. The correct string format is provided below the
field as a guide.
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•

Click Load.

•

Select the necessary user from the list of loaded users.

•

Click Import. The domain name and the user name from Active Directory appear in
the AD Login Info field.

11. Confirm the login information specified by clicking the Validate button.
12. If you want the user to be created with the license instance admin permissions, select the
License Instance Administrator check box.
In previous versions of License Server, instance administrators also consume a product
license but do not necessarily use the product for which the License was created. In
License Server v15.0, a license instance administrator does not consume a product
license, which means this license may be utilized by an actual user.
13. Tick the box for License Check Out Enabled if you want the user to be able to check out
his/her license and work offline with Monarch.
14. If license check out is enabled, specify a maximum time (in days) allowable for check out
in the box provided.

NOTES
In general, when working with a Monarch installation activated via
the License Server, a user will require a continuous internet
connection.
When License Check Out is enabled, a user may check his/her
license out and use Monarch in offline mode. This feature is
particularly useful, when, for example, the user is travelling and
may not have reliable access to the internet. When the maximum
time allowed for check out has elapsed, the user must check in the
license and log back into Monarch using License Server
authentication. Otherwise, the user’s account will be frozen and
he/she will be unable to continue working with the application.
When a user checks out a license, this action is interpreted as a
logout when a server report is run.
The maximum allowed time for checkout depends on the value
specified when the license was created.

15. Tick the box for Automatic License Check Out Enabled and then specify a number of
hours within which the license must be renewed before expiration.
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Note that this option is only enabled when the License Check Out Enabled option has
been selected. This new feature in License Server v15.0 is useful in sporadically connected
user environments and allows accommodation of massive user traffic. It also minimizes
user downtimes due to upgrades, migrations, etc. Automatic license checkout can be
enabled at the server, instance, and user levels.
16. Click Save. The newly created user appears in the users list in Server Explorer and in the
content pane.

NOTES
You can enable both or only one of the authentication types for
the user by completing either both or only one of the fields –
Password or AD Login Enabled.
Only the Name, Password, and Confirm Password are mandatory
fields.

You can also add users by importing them. For more information, see Importing and Exporting
Users.
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Filtering Users
You can filter the Users List for better user management.

Steps:
1. Load the Users List of any instance and then click on the filter icon to the left of any
column name.
2. Use the drop-down menu that displays to filter the user list. Click Filter when you are
finished to complete the operation or Clear Filter to go back to the users list.

Note that filtered user lists can be exported by selecting Users > Export Filtered to CSV
or Actions > Export Filtered to CSV.
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Viewing User Details
Steps:
1. Click the required user in Server Explorer under Users List or in the content pane. The
user details are displayed in the content pane.

2. You can edit the user in the user details pane or you can click Cancel to go back to the
users list.

Editing User Details
Steps:
1. In Server Explorer, click the required server name, click the name of the instance to which
the user belongs, and then click Users List. Click the user under Users List in Server
Explorer.
2. Click the name of the user whose details you wish to modify. The user details are
displayed in the content pane.
3. In the User Details pane that displays, make the necessary changes and then click Save.
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The modified details of the user are saved, and the updated Users table is displayed in the
content pane.

NOTES
The License Instance admin check box in the user details is shown
only to the system admin user.

Editing User Settings
User settings (e.g., enable/disable login, delete user, etc.) may be modified via the Actions
drop-down.

Steps:
1. In the User list panel, tick the box adjacent to the user(s) whose settings you wish to
modify.
2. Click the Actions
utility.

icon located at the lower right-hand corner of the configuration

The Actions menu displays.
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3. Select the action you wish to apply to the user(s) selected.
You can:
•

Enable the login(s) of selected user(s)

•

Enable all logins

•

Disable the login(s) of selected user(s)

•

Disable all logins

•

Delete user(s)

•

Delete all users

•

Enable automatic license checkout

•

Disable automatic license checkout

•

Enable checkout for selected users

•

Disable checkout for selected users

•

Export selected users to CSV file

•

Export filtered users to a CSV file

•

Export all users to CSV file

Importing and Exporting Users
You can import users to Datawatch License Server in a number of ways, including:


Importing from an old license file (this option is available only for Monarch users)



Importing from Active Directory

If you need to transfer a number of users from one instance to another, you can export users
to a CSV file (a Comma-Separated Values file) and then import users from the CSV file.

NOTES
When importing users, a default password (password) is set for
the users. By default, all product features are assigned to imported
users. Roles are not assigned by default to imported users.
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You can import users of another license file used previously in Monarch 14.0 or higher.

Steps:
1. In Server Explorer, do either of the following:
•

Select Users > Import from old license file from the Configuration menu.

•

Navigate to the instance to which you want to import users, right-click on Users List,
and then select Import from old license file from the menu that displays.

2. In the Import from old license window that appears, click Browse to locate the old
Monarch license file.
3. Click Load.
4. Select the necessary users from the list.

5. Click Import. The imported users appear in the users list in Server Explorer and in the
content pane.
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You can import users from Active Directory of the specified domain within your network.

Steps:
1. In Server Explorer, do either of the following:
•

Select Users > Import from Active Directory from the Configuration menu.

•

Navigate to the instance to which you want to import users, right-click on Users List,
and then select Import from Active Directory from the menu that displays.

The Import from Active Directory dialog displays.
2. Specify the domain name in the field provided.
3. If you wish to perform an LDAP query, tick the box for LDAP query and then enter a
search string into the field provided. The correct string format is provided below the field
as a guide.

4. Click Load.
5. Select the users you wish to import from the list that displays.
6. Click Import. The imported users appear in the Users List in Server Explorer and in the
content pane.
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Steps:
1. In Server Explorer, do either of the following:
•

Select Users > Import from CSV from the Configuration menu.

•

Navigate to the instance to which you want to import users, right-click on Users List,
and then select Import from CSV from the menu that displays.

2. In the Import from CSV dialog that appears, click Browse.
3. Select the necessary file in .csv format and click Open. The users from the file appear in
the Import from CSV window.

4. Click Load.
5. Select the necessary users from the list.
6. Click Import. The imported users appear in the users list in Server Explorer and in the
content pane.

Steps:
1. In Server Explorer, do either of the following:
•

Select Users > Export to CSV from the Configuration menu.

•

Navigate to the instance from which you want to export users, right-click on the Users
List, and then select Export to CSV from the menu that displays.

•

Navigate to the instance from which you want to export users, select specific users to
export, and then select Users > Export Selected to CSV from the menu that
displays.
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Note that you can also use the Actions drop-down located at the bottom of the Users List
to export users.
2. In the Save As window that appears, specify the name and location for your CSV file and
click Save. The file is saved into the specified location.
3. Click OK to acknowledge successful export operation.
After you have exported users to a CSV file, you can import them from this file when
required, for example, when you need to transfer a batch of users to another instance.

Ending User Sessions
Super-administrators may use the following CMD commands to force-end user sessions:


Datawatch.LicenseServer.ConfigurationUtility.Shell.exe instance=Monarch13 -forceEndAllSessions -admin=AAA -password=BBB



Datawatch.LicenseServer.ConfigurationUtility.Shell.exe instance=Monarch13 -forceEndSession="User1;User2..." -admin=AAA password=BBB
where: AAA = the super-administrator username, BBB = the super-administrator
password

NOTES
These commands must be executed from the folder in which the
Datawatch.LicenseServer.ConfigurationUtility.Shell.exe file is
located.

Super-administrators may opt to:


forceEndAllSessions – Ends all sessions



forceEndSession=User1 – Ends User1 session

The forceEndSession command may include multiple values separated by a semicolon, i.e.,
forceEndSession="User1;User2" ends sessions for User1 and User2.
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Datawatch License Server
Settings

Datawatch License Server settings can be modified at the global and instance levels.
Among the global settings License Server administrators can specify are:


Administrative Settings – You can specify various policy scopes as well as whether to
allow instance administrators to set policies.



Security Settings – You can modify various password settings.



Active Directory Settings – You can map the DNS name of the AD server to its NetBIOS
name.



Connection Options – You can specify how the length of time allowable before a user’s
session times out.



Licensing Settings – You can specify whether client-side notifications for licenses about
to expire should be displayed as well as license checkout options.



Language – You can change the language of your License Server to French or English.



Credentials – You can change your password if you are the system admin user.

Global Options
To access the Server Options dialog, right-click on the server name and then choose
Options… from the menu that displays. Alternatively, in the Settings menu of the Datawatch
License Server Configuration Utility, select Options.

In previous versions of the application, users, sessions, and reporting were managed only at
the instance levels and certain options were only managed at the server/global level. To
accommodate clients with more complex requirements for server administration, in License
Server v15.0, application administrators may now specify policy settings at the server level
and opt to delegate policy-making to instance administrators.
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This feature provides the following benefits:




Enables safe defaults when creating new instances
•

Initial state for a new instance is server-scope

•

Server-scope settings are inherited

Enables multiple administrative approaches
•

Single administrator

•

Delegated administration

•

Delegated user management

Administrative policy settings are specified in the Administrative Settings tab of the Server
Options dialog.

Steps:
1. Tick the box to the left of a server instance for which you wish to specify administrative
settings.
2. Click on the field adjacent to the selected server instance name under Security & Alerts
Policy Scope and then use the drop-down that displays to specify whether these policies
should be implemented at the Server or Instance level.
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3. Click on the on the field adjacent to the selected server instance name under Checkout
Policy Scope and then use the drop-down that displays to specify whether these policies
should be implemented at the Server, Instance, or User level.

4. Specify whether instance administrators can be created for the selected server instance.

When enabled, the Allow Instance Administrators option allows the creation of
instance administrators. When disabled, instance administrators cannot be created and the
corresponding option is disabled in the new user addition form.
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5. Specify whether instance administrators can set policies for the selected server instance.
When enabled (and instance administrators are allowed), the Instance Administrators
Can Set Policies option allows instance administrators to change policies on instances
that are not set to the Server scope. When disabled, instance administrators are limited to
user management.
6. Click Apply to save your settings and then Exit to close the dialog.

Steps:
1. Click Security Settings in the Server Options dialog.

2. In the Server Authentication Settings tab of the dialog, specify a password complexity.
•

Choose the minimum number of characters a password must have.
Note that the maximum password length is 256 characters.

•

Tick the corresponding boxes adjacent to the feature if you’d like password to include
uppercase characters, lowercase characters, digits, and nonalphanumeric characters.

3. In the box provided, specify the number of days that must pass before passwords expire.
Note that the maximum days a password will remain valid before expiring is 365 days.
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4. If necessary, click Expire All Passwords Now to force all passwords specified for all
users to expire immediately. In this case, users must create a new password the next time
they log into Monarch.
5. Tick the box for Force change password on first login for new users if you want
users to change their passwords the first time they log into Monarch.
6. Under Other Options, tick the box for Disallow saving credentials for clients if you
want to prohibit users from saving their credentials when they log into Monarch.
If this setting is enabled, users logging into Monarch will be unable to save their username
and password. Thus, each time they use the application, they must supply this
information.
7. Tick the box for Require Active Directory Authentication if you wish to force users to
authenticate their credentials via Active Directory.
Note that if this option is enabled, only system administrators will be able to log in using
username/password authentication.
8. Service Security Scheme Settings allow administrators to configure the License Server
scheme via the License Server Configuration Utility.

Under Basic Authentication, use the drop-down provided to specify whether basic
authentication should be performed via the HTTP or SecuredHTTPS scheme.
9. If you selected SecuredHTTPS in Step 8, provide the subject name of the corresponding
SSL certificate.
•

Windows – used when License Server and the machine in which the Monarch instance
to be licensed belong to the same or trusted domains

•

Anonymous - used when License Server and the machine in which the Monarch
instance to be licensed do not belong to the same or trusted domains

10. Click Apply to save all of your password specifications and then Exit to close the dialog.
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When importing users from Active Directory, you may need to map the DNS name of the AD
server to its NetBIOS name to correctly identify it.

Steps:
1. Click the Active Directory Settings tab of the Server Options dialog.
2. Click into the DNS name field and then specify a DNS name.
3. In the box adjacent to this field, specify the corresponding NetBIOS name to which the
DNS name should be mapped.

4. Click Apply to save your specifications and then Exit to close the dialog.

License Server administrators can specify how long user sessions remain active before timing
out and resetting. This feature solves the problem of a user accidentally being locked out of
and unable to log into Monarch when it crashes or the service is terminated.
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Steps:
1. Click Connection Settings in the Server Options dialog displays.
2. In the Connection Settings tab, specify a number of hours, minutes, and seconds that
can pass before a session times out.

Note that by default, sessions will automatically time out after a minimum of 5 minutes
and a maximum of 24 hours.
3. Specify Service Performance limits.
•

Maximum Concurrent Calls - This is the limit of concurrent calls from all clients and
includes events such as logins, logouts, session heartbeats, check-ins, and checkouts.
Once this limit is reached, requests are queued and delays will occur. The default limit
is 16 × [Number of logical processors].

•

Maximum Concurrent Sessions - This is the limit of concurrent sessions and applies
to server authentication over SecuredHttp and Active Directory. Once this limit is
reached, requests to create further sessions are queued until a slot becomes available.
The default limit is 100 × [Number of logical processors].

•

Orphaned Connection Timeout - This is the period after which the service drops
orphaned connections and returns the resources to the pool. The default limit is 5
minutes, and the minimum limit is 1 minute.

4. Click Apply and then Exit to close the dialog.
The License Server Configuration Utility saves your specifications.
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License Server administrators can specify whether Monarch should display notification to
clients when a license is about to expire as well as license checkout options.

Steps:
1. Click on the Licensing Settings tab of the Server Options dialog
2. Under Notification Settings, tick the box to suppress client-side license expiration
notifications.
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3. Under License Check Out Options, tick the box for Allow license check out for if you
wish to allow license checkout and then specify a number of days after which a license
will expire in the time field that displays.
Note that the actual amount of time a license can be checked out may be different from
the value indicated in this dialog (e.g., the value specified in this dialog is larger than the
value allowed for a specific instance).
4. Tick the box for Force clients to check out automatically when connecting to
License Server if you wish to force automatic checkout and then specify a number of
hours within which the license must be renewed before expiration.
5. Select Apply and then Exit to close the dialog.
The License Server Configuration Utility saves your licensing settings.

Instance Options
License Server settings may also be specified at the instance level. To do so, right-click on an
instance name and, from the options that display, select Options.
The following settings may be specified at the instance level:


Language



Security Settings
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Licensing Settings

Credentials
Users can change their username and password.
Note that only administrators can change the admin password.

Steps:
1. In the Settings menu of the Datawatch License Server Configuration Utility, select Change
Credentials.
2. In the Change Credentials window that appears, specify the old and new
usernames/passwords.
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3. Re-enter the new username/password to confirm.

4. Click Change.

Language
To change the language applied to the License Server, log into the Datawatch License Server
Configuration Utility and then select Settings > Language. In the menu that displays, select
the language (i.e., French or English) you wish to apply. The figure below, for example, shows
the License Server in French.
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Troubleshooting
If you are unable to connect to a license server, verify that the License Service component of
Datawatch License Server is started. To do so, go to Windows Start menu > Administrative
Tools > Services, find Datawatch License Service in the list, and verify the value in the
status column. If License Service is not started, right-click Datawatch License Service and
select Start.

Logging Levels
Log files for the License Server Service and Configuration Utility are typically located in
C:\Program Files\Datawatch\Datawatch License Server\Service\Log.
The amount of information found in log files may be modified by accessing the corresponding
config files:


Datawatch.LicenseServer.Service.LicenseService.exe.config



Datawatch.LicenseServer.ConfigurationUtility.Shell.exe.config

Locate the following configuration elements and then alter the value of the switchValue
attribute.

<loggingConfiguration>
<categorySources>
<add switchValue="Information" autoFlush="true" name="General">

Acceptable values include the following:
Value

Description

Off

No information is recorded

Critical

Logs unhandled exceptions including:
•

OutOfMemoryException

•

ThreadAbortException (the CLR invokes any
ThreadAbortExceptionHandler)

•

StackOverflowException (cannot be caught)

•

ConfigurationErrorsException

•

SEHException
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Value

Description

•

Application start errors

•

Failfast events

•

System hangs

•

Poison messages: message traces that cause the
application to fail

Error

Logs all exceptions

Warning



Logs events that have occurred or may occur and cause
an otherwise normally running application to
malfunction.



Information is recorded when:

Information

Verbose

ActivityTracing

All
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•

The application is receiving more requests than its
throttling settings allow.

•

The receiving queue is near its maximum
configured capacity.

•

Timeout has exceeded.

•

Credentials are rejected.



Default logging level



Logs events indicating successful application execution
regardless of whether the application is working
properly or not. The application is considered
successfully executed when:
•

Channels are created.

•

Endpoint listeners are created.

•

Message enters/leaves transport.

•

Security token is retrieved.

•

Configuration setting is read.



Logs low-level events for both user code and servicing



Used for debugging purposes

Logs events that allow administrators/developers to
correlate applications in the same application domain. This
information includes:
•

Traces for activity boundaries (e.g., start/stop)

•

Traces for transfers

Logs all previous events

Note that the logging value selected includes the information captured by the logging value
above it, except for Off. For example, a logging level of Warning includes Critical, Error, and
Warning information. The value All includes events from ActivityTracing to Critical.
The application must be restarted for changes to this setting to take effect.
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